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Login

* login to Rangeer, using your train<xx> account:

ssh -X train<xx> ranger.tacc.utexas.edu

« Untar the file tau.tar file (in ~train00) into your directory:

tar xvf ~train00/lab_tau_long.tar
cd tau_long
source sourceme.csh {c shell}
or
sourceme.sh {Bourne shell}

*Completed runs are available in lab_tau_long_done.tar.
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gprof

Gprof is a utility for discovering how much time subroutines, library calls
and intrinsic functions are using. Code must be “instrumented” (compiled)
with “-g” (or some similar option) to provide a symbol table in the
executable. There are two subroutine calls and two intrinsic functions
calls used in the program long.f. Instrument this program and run the
executable to obtain a (binary) trace, gmon.out, with timing information.
On Linux systems the compiler commands are.

Linux: login3% ifort -g -p long.f90 {intel compiler}
Linux: logind% pgif90 -g -p long.f90 {pgi compiler}

(used “source ./sourceme.csh” (C shell) or “ . /sourceme.sh” (Bourne shell) to access ifort)

Execute a.out to make a report:

Ja.out _ |
gprof > gprof_report }Interactlve Session

Read the man page on gprof to help make sense of the 2" part of the listing--
the display information about time spend in parent and children processes.

(The do_gprof will perform all of the operation above: just execute “do_gprof”.
Draw a diagram showing the tree structure of the calling sequence.



Memory Maps

Memory maps provide a list of the layout of the TEXT (code),

DATA (initialized variables), and BSS (uninitialized variables) memory
regions. It is often used to discover which libraries have been loaded
by the linker. Compile the long.f program, using an appropriate
linker option to produce a “load map” of the program.

Linux: login3% ifort -WI,-Map,map_output long.f90

You can use the do_map script to execute the above command(s),
and produce a map. On a Linux machines it will also produce a vector
report. Where is the cos library function coming from
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TAU

First load up the TAU environment.

% cd tau_long (if you are not already there)
% source sourceme.csh or % . sourceme.sh {for C/Bourne shells, respectively}

The PDT is used to instrument your code; but it is necessary to describe all the
component that will be used in the instrumentation (mpi, openmp, profiling, counter
[PAPI], etc. But these come in a limited combination. First determine what you
want to do (profiling, PAPlcounters, tracing, etc.) and the programming paradigm
(mpi, openmp), and the compiler. PDT is a require component:

- PDT

- PROFILE
- MP

- PAPI

* intel
* pgi
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TAU

You can view the available combination by using the command:
% tauTypes
These are called TAU stubs for makefiles.

Look in the sourceme.csh or sourceme.sh file. Here are some of the
operations done for you:

unload mvapich

swap pgi intel Use Intel Compilers
load mvapich
module load kojak pdtoolkit tau Loads Tau & Papi

Set the TAU_MAKEFILE environment to the correct stub (full path)
setenv TAU_MAKEFILE .../Makefile.tau-icpc-mpi-papi-pdt
setenv TAU_OPTIONS ‘-optVerbose ...’ {see tau_compiler.sh}

Sets TAU_MAKEFILE
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TAU

If you have a single-file program, you can use the Tau compiler wrapper directly:

instead of
mpif90 foo.f90

use
tau f90.sh foo.f90

Look in the Makefile, to see how this is done for the matmult.f90 problem.

Now make the matmult executable and submit the job with the commands (look
over the job script):

% make
% qsub job

Analyze performance data:
% pprof (for text based profile display)

% paraprof (for GUI)
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TAU: ParaProf Manager

Two windows will appear. This is the manager window, showing the experiment.
Note, it has all the details use in the “trial”.

76 O 6 X! TAU: ParaProf Manager
File Options Help
@ Applications TrialField Yalue
¢ [CJ Standard Applications Name tau/debug_examplesfcarlos/01157 /h...
¢ [ Default App Application ID 0
¢ [ Default Exp Ex.periment 1D 0
¢ [ taujelbwg=axamples fcarlos /0115 I;‘ﬁll_l_?m.__ 2
o EE{ILMEB?'D CPU MHz 2293.908
@ PAPI L1 DCM CPU Type Quad-Core AMD Opteronitm) Processo...
o7 CPU Yendor AuthenticAMD
CWwD Jfsharefhomef01157 fcarlos/debug_ex. ..
Counters we asked for | |cachesize 312 KB
¥ecutable fsharefhomef01157 fcarlos/debug_ex. ..
Hosthame i115-101.ranger.tacc.utexas.edu
Local Time 2009-03-18T14:16:48-05:00
MPIl Processar Name i115-101.ranger.tacc.utexas.edu

'

Memory S

22878720 kB
i115-101.ranger.tacc.utexas.edu
¥86_64

Linux

2.6.18.8. TACC.lustre.perfctr

#4 SMP Tue Jul 22 07:16:12 CDT 2008
1227403802413938

¥86_64

TAIl Config -prefix=joptfapps/pgi7_2 fmvapichl_...
TAL Version 2.17

Timestamp 1227403808551516

UTC Time 2009-03-18T19:16:482

pid 12107

username carlos




"® O O |X| TAU: ParaProf: /share/home/01157/carlos/debug_examples/tau

Tau: Metric View

In a second wind, the default “GET_TIME_OF DAY” profile information
will appear. You switch between metrics, by double-clicking** on the green
bullets next to the names in the manager window (see previous slide).

File Options Windows Help

'M etric: GET_TIME_OF_DAY
Yalue: Exclusive

std. dev.
mean

nct0,0,0
nctl1,00

hct2,00

hct 3,00

n,ct4,0,0

nhcts,00

nct 6,00

hct 7,00

nct 80,0

nct10,0,0

nctl1ll,0,0

nct12,0,0

n,ct13,0,0

n,ct14,0,0

|
|
|
|
|
|
|
nct 9,00 |
|
|
|
|
|
|

il

n,ct 15,0,0

Information includes
Mean and Standard
Deviation

Windows->Function
Legend

® O O [X| TAU: ParaProf: Function Legenc
File Filter Windows Help

'@ MPI_Allgather

B MPI_Allreduce(

O MPI_Attr_putd

[ mMPI_Barrierp

B MPI_Bcast)

B MPI_Comm_create(
[ MPI_Comm_free(

] MPI_Comm_group
O MPI_Comm_rank(

O MPI_Comm_sizeQ

[ MPI_Comm_splitd

B MPI_Errhandler_set(
[ MPI_Finalize(

[ MPI_Group_freed

E MPI_Group_incl)

B MPLInit

E MPI_Recv)

O MPI_Sendd

B MPI_Type_commit(
B MPI_Type_contiguous)
] MPI_Type_structd

] int main(int, char *) C
[ void initialize{double *, double *, int) C
O woid multiply_matrices(double *, doukle *,

< i [ H

**This can be a sensitive operation, try several speeds of double clicking.



Tau: Metric View

Unstack the bars for clarity: Options -> Stack Bars Together

e 06 X! TAU: ParaProf: /share/home/01157/carlos/debug_examples/tau
File Options Windows Help

'Metric: GET_TIME_OF_DAY
Yalue: Exclusive

std. dev.
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Hoover over bars with mouse to see time for each function call.
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Tau: Function Data Window

Click on any of the bars corresponding to function multiply_matrices. This opens the
Function Data Window, which gives a closer look at a single function.

r N
® O O x| TAU: ParaProf: Function Data Window: /share/home/01157/carlos/debug_examples/tau
File Options Windows Help
Name: void multiply_matrices{double ™, double *, double ™, int) C [{matmultc.c}{114,1}-{123,1}]

Metric Name: GET_TIME_OF_DAY

Walue: Exclusive

Units: seconds

3.849 | | n,c,t 14,00
3.849 | | nct7,00
3.84¢6 | | nct15,00
3.846 | | nct4,00
3.845 | | nc,t12,0,0
3.843 | | nct1,00
3.842 | ] nct2,00
3.841 | | nct13,00
3.834 | | mean
3.827 | | nct3,00
3.824 | | nct5,00
3.822 | | nc,t11,0,0
3.822 | | nct6,00
3.821 | | n,c,t 10,0,0
3.82 | | nct80,0
3.818 | | nct900
|

std. dewv.




Tau: Float Point OPS

Now, go back and display the PAPI_FP_OPS (double click the PAPI_FP_OPS metric
in the manager window. Click a bar corresponding to the function multiply_matrices
In the ParaProf Metric Window select Options -> Select Metric -> Exclusive

-

.
e 06 N TAU: ParaProf: /share/home/01157/carlos/debug_examples/tau
File Options Windows Help

Metric: PAPI_FP_OPS
YWalue: Exclusive

std. dev. [

mean | |
n,ct 0,00
nct 1,00 |
nct2,00 |
n,ct 3,00 |
nct4,00 |
ncts,00 |
nct 6,00 |
nct 7,00 |
nct 8,00 |
|

|

|

|

|

|

|

Note the disparity and grouping of the FLOPS performance.



Tau: L1 Cache Data Misses

Now, go back and display the PAPI_FP_OPS (double click this metric
in the manager window. Select Options -> Stack Bars Together to see differences better.

~

-
e 06 N\ TAU: ParaProf: /share/home /01157 /carlos/debug_examples/tau
File Options Windows Help

| Metric: PAPI_L1_DCM

Yalue: Exclusive

std. dev.
mean

nct 0,00
nhct 1,00
nct 2,00
hct 2,00
hct 4,00
ncts,00
nct6,00
nct 7,00
nct 80,0
nct 9,00
h,c,t 10,0,0
nct11,0,0
nhct 12,00
nct 12,00
nct 14,00
nh,ct 15,0,0
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Now, click a bar corresponding to the function multiply_matrices
to see just the matmult results. -- These look similar to the FP_OPS profiles.



Derived Metrics

« ParaProf Manager Window -> Options -> Show Derived Metrics Panel
« Select Argument 1 (PAPI_L1 _DCM) and Argument 2 (PAPI_FP_OPS)

« Select Operation (Division) & Apply

(© 66 X| TAU: ParaProf Manager
File | Options | Help
@ Ap| ¥ Show Derived Metric Panel | MetricField VENE
¢ [CJStandard Applications MName PAPI_FP_OPS f PAPI_L1_DCM
¢ [ Default App Application 1D 0
> - Experiment ID 0
Default Ex
' l:—]l__:hdau 'L‘iPFbJIJ"I examples/carlos/011% Trial 1D 0
v u/cenug._exampies/aro=/O1 13 Ay etric 1D 3

@ GET_TIME_OF_DAY
@ PAPI_FP_OPS
@ PAPI_L1_DCM
@ PAPI_FP_OPS j PAPI_L1_DCM

< | »

Argument 1: 0:0:0:3 - PAPI_FP_OPS j PAPI_L1_DCM
Argument 2. |0:0:0:1 - PAPI_FP_OPS

Divide |w Apply operation




Derived Metrics (Cont.)

Select a Function
Function Data Window -> Options -> Select Metric -> Exclusive ->

e re © © (x| TAU: ParaProf: Function Data Window: /share/home/01157/carlos/debug_examples/tau )
File | Options | Windows Help

Narn{ - Show Find Panel ¥, double *, double *, int) C [{matmultc.c}{114,1}-{123,1}]
Metri ¥ Show Meta Data in Panel DCM

valug gy Descending Order

Units
IJ Show Values as Percent

372 Select Units... » 1 nc190,0
372 Select Metric.. »  Exclusive.. » O GET_TIME_OF_DAY 5.0.0
371  Sort by... »  Inclusive... »| O PAPI_FP_OPS 8,0,0
g?i—;‘;{__ Exclusive per Call..  » O PAPILL1_DCM ﬁ'g'g
371178 = Inclusive per Call..  »/ @ PAPLFP_OPS | PAPLLL.DCM | 7 ¢ ¢
371,055 e ] © Number of Calls e | nct 4,00
370153 il O Number of Child Calls ] 0,0t 6,0,0

367976 o e 0000 | mean

365,017 ] n,C,112,0,0
34863 o | nt 13,00
4479 | ngt 15,0,0
363914 L i ngt 10,0
363537 o ... | nct300
363505 o oo nct 14,00
363308 bbb o i gt 2,0,0

3.687 [l std. dew

/4



Callgraph

Important, save your present Tau data: mkdir save; cp —R MULTI* save

To trace the function calls within the program, follow the same process
as before, but use the following TAU_MAKEFILE:

Makefile.tau-callpath-mpi-pdt-pgi
Here are the commands:
% source sourceme_callpath.csh

% : sourceme_callpath.sh
% make clean
% make

% qsub job _callpath

cd down to call path * and execute paraprof:

In the Metric View Window, two new options will be available under:
Windows =» Thread = Call Graph

Windows =» Thread = Call Path Relations

Verify the calling structure of the call tree is similar to the gprof tree.



mpiP
Load the mpiP module:
% module load mpiP
% source sourceme_mpip.csh {C shell}
% source sourceme_mpip.sh {Bourne shell}

Link the static library before any others:
% mpif90 -g -L$TACC_MPIP_LIB \
-lmpiP -1bfd -liberty ./matmultf.f90

Try the compilation above with the map option (-WI,-Map
mapout), with and without MPIp, and determine which MPI
library is satisfying the code’s MPI calls:

% mpif90 -WI,-Map map_mpip -g -L$TACC MPIP LIB \
-lmpiP -1bfd -liberty matmultf.f90

% mpif90 -WI,-Map map_nompip matmultf.fo0
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mpiP

Set environmental variables controlling the mpiP output in
the job_mpip script (for C shell):
% setenv MPIP ‘-t 10 -k 2’ {See job _mpip script.}

In this case:

-t 10 =» only callsites with time > 10% MPI time reported
-k 2 =» set callsite stack traceback depth to 2

Run program through the queue as usual.
% qsub job _mpip

Display results.
% mpipview <app_name><unique number>.mpiP
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mpiP

In the slave nodes, which collective and point-2-points MPI
calls take the most time? What does the master spend mode
of its time doing in MPI?
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